Firmware Releases

Home Forums Products (arches) Firmware Releases

This topic contains 52 replies, has 10 voices, and was last updated by  Davide Mancini 1 year, 1 month ago.

Viewing 8 posts - 46 through 53 (of 53 total)
  • Author
  • #12520

    Davide Mancini

    Hi Scott,
    Just uploaded the last firmware with external clock problem solved (it was only a ‘UI’ problem, as the visualizzation got messed up while the outputs were correct! Thanks for yuor note.
    I con’t understand the preset thing. The problem is that you cannot load OLD preset or the new ones?
    Let me know, thanks.



    Ciao Davide

    Grazie mille for the external clock fix!

    I have erased the presets and loaded firmware 1.0.7 with a fresh copy of the presets.

    The Seq UI still turns off on the first cycle with the external clock enabled, and then goes into a mode where all the lights are off and flash once. On and flashing on activation would be helpful, same as how it works for internal.

    The Trigger Seq settings are not loading correctly from a new preset. Steps to reproduce:
    1. Start with the default preset that loads when powered on.
    2. Enable the Step Seq. This should have a default setting of up/1/16%/8/Free etc
    3. Enable all of the Trigger Seqs. You should only need to Enable them, they are initialized with up/1/16%/8
    4. Save new preset, I used 5
    5. Power off.
    6. Load preset, I used 5
    7. Trig Seq 1 does not load correctly. Enabled is false, Type is blank, Clock Div is “es minor”, Gate Length is glitched display (I will send you an image via FB). Track Length is 9.
    8. Trig Seq 2 does not load correctly. Enabled is false, Type, Clock Div, and Gate Len are blank, Track Length is 1, Mode is glitched display
    9. Check the other Trig Seqs–they’ll be out of sorts as well.

    Should these steps not work on your Arches, kindly send MD5 or SHA hashes for the files so I can verify that I have the right firmware and presets.

    PS. Please consider a web page UI for the configuration. For instance HexInverter’s Mutant Brain has a comparably complex configuration which can be programmed over MIDI with a web page.



    This latest firmware update 1.00.07 announces itself on the arches OLED screen as 1.00.05


    Davide Mancini

    Hi there!
    Please check out the correct file name. IT can happen that, when you unzip the file, a suffix appears (like “archesim4.hex”). The correct file name is ALWAYS:
    If I am correct what happened in your case is that you reflashed the unit with more than one file in the SD card, and it took the old one (1.0.5).
    let me kwow!

    The 1.0.7 version display correctly when you use the correct file.



    I’ve tried loading all three versions of the arches firmware (1.00.00, 1.00.05 & 1.00.7) , and even with no micro SD inserted, the OLED shows 1.00.05 as the loaded firmware version.


    Davide Mancini

    Hello, (arches) starts and works as intended even without an inserted SDcard.
    Obviously you won’t be able to load/save pattterns but everything is operating.
    As you upgraded to 1.0.5 you should be able to do also with 1.0.7.
    Trying to describe a more robust procedure:

    -Delete every file that are on the root of the SD card (leave the /ARCHES directory as is)
    -now, unzip the firmware zip file that’s on the (arcehs) page and, IF NEEDED, rename the hex to: “archesim.hex” wihtout any appended number.
    -insert sd card
    -press both encoder and give power to arches (you should see the ‘lightshow’ flash upgrade phase and then the arches will boot to 1.00.07

    Let me know!



    Solved…I’d deleted the autoprog.bcm file, but forgotten that now have to hold the 2 encoders down when loading the firmware!

    It works OK now.


    Davide Mancini

    Now we are working on the preset load/save problems with trigger sequencer…!!!

Viewing 8 posts - 46 through 53 (of 53 total)

You must be logged in to reply to this topic.