Issues reporting

Home Forums Products (arches) Issues reporting

This topic contains 81 replies, has 12 voices, and was last updated by  porb 2 months, 2 weeks ago.

Viewing 15 posts - 16 through 30 (of 82 total)
  • Author
  • #11338


    I am totally ok when a product I found on Kickstarter delivers late. I am also ok when there are some software quirks and I do some beta testing for a manufacturer.

    But I am not ok if the software lacks advertised features, is not even a beta but more an „alpha in progress“ and on top of it all, there are no frequent firmware updates and a non existent communication from side of the manufacturer.

    If Kickstarter would allow it, i would like to go for a refund, but unfortunately we all now hang here with an unfinished product that does not meet our expectations.

    What now, sound machines? It’s your turn to deliver.


    Davide Mancini

    Hello to everyone.
    I am really sorry for the problems that some of you are experiencing and, first of all, for not being able to cope with communication here.
    Mainly we are working to finish the two sequencers, trigger and stepseq. Because we want to produce something correct and, possibly without added ‘issues’, we are checking the functions very carefully. Dev should end this week and I will take the weekend to re-test it with different equipment. At the same time we are taking in account of your reports on some key aspects and bugs.
    Definitely some of the features (mainly the midi/clocking stuff) need more attention especially given that syncing to other equipment have to take in account lots of aspects (pulses width and amplitude, etc..) and it’s quite impossible to test all the possibilities.
    I will append to the end of this message a series of focused questions for some of you.
    Reagrding the hardware. As I wrote in other spaces I think that the dual nature (standalone/eurorack) of the arches put some limitations on the ‘finish’ aspect (and also substance) of the product, screws on the front plate’, less than perfect assembly and application of materials like the overlay, etc.. In hindsight I would have chosen a single product, maybe just the standalone. It’s not unlikely that we will build in the near future a flush case, maybe in machined wood, that solves many of the described issues with assembly. The aspect of the distance’ between the panel and the metal case is something we underestimated with the protos. This is due to the height of the studs/bolts that allows the panel to be screwed. As I wrote in another forum thread, there is no actual ‘physical’ and electrical problem with this ‘gap’ but I understand that the feeling is not very ‘confident’. We struggled a bit also to find a good layering of overlay materials to have a low interference with the touch technology, a good ‘feel’ for the fingers and a ‘removable’ type of adhesive. We are looking for a viable solution to the ‘gap’ thing.
    This is a very important product for soundmachines and all of us are now wokring on the firmware to have it done right. There will be probably some other issues arising from the field usage in the future and we will address those as fast as we can. We know this is a ‘bumpy’ start that is bound to the complexity (either firmware and hardware/assemply) and we are going to have things set down correctly and smoothly.
    Again, sorry for the issues BUT we are definitely going to solve those.
    A few questions now:

    A-There is a bug (fixed in next version) in UI that reverses the meaning of MIDI CLOCK OUT

    B-As we are writing this, the MIDI CLOCK is NOT sent, by design, on the BLUETOOTH channel. USB has a bug and it don’t send CLOCK OUT when also sending NOTES (solved) but, contrary to what I have read in one post, the MIDI DIN outputs midi clock correctly. Please be sure to have set ‘MIDI I/F’ to DIN.

    C-CKIN: it seems that some of you have used it correctly (at least with some equipment) and others never get to use it. To enable the CKIN you have to select ‘config’ menu CLOCK SOURCE as CLK IN and confirm that. Due to the bug described above, set to the MIDI CLK OUT to ‘ON’. There could be some interferences in the firmware. I checked the CLK IN with a simple LFO right now an the arpeggiator is running OK. PLease tell me the modules/equipment that you are using to drive the CKIN input on (arches) so I can check out the specs and voltages.

    D: MIDI CLOCK IN —> CKIN clock out. This HAVE to work. We check the output functionality for each product during the testing and the simple sequence is having LIVE outputting MIDI CLOCKs on the DIN interface and switching teh clock to external I see the BPM changing on the fly on the CKIN output.
    Let me know if you are NOT experiencing this and what is the (arches) configuration!

    E:I will check also the ‘tuning’ thing that happend to one of you. The Reference to the DACs is a very precise IC and doesn’t have particular problems in outputting the buffered voltage. I am thinking about a bad table load (as you know you can change standards on the arches, buchla etc). Did you changed this setting before the issue appeared?

    Awaiting for your feedbacks.

    PS I set the notifications on all the threads so this will allow us to be ontime in a better way.



    Hi Davide and thank you for your comments.

    I posted the note about the tuning/pitch scaling problem. I didn’t deliberately change the scaling voltages. In fact, I have yet to read about how to do that.



    I’m feeling like the crosstalk between the 5th and 6th buttons is a pretty major thing, does everyone else have this or is it just Umcorps and myself?



    I have the same problem with the 5th and 6th buttons.



    I can also confirm that the 6th button, if pressed on the left side, triggers button 5


    Davide Mancini

    I’ve checked the units here in house, we have almost twenty ready for shipment and only one has a similar behaviour, but frankly the ‘finger’ is already on the 5th button when it triggers it so I won’t call it a ‘positive’ ike the ones you are reporting.
    Anyway, modifying sightly the calibration config isn’t be a big issue. We will rise a little bit the threshold for ‘pressed button’ on that two.
    Concurrently we will measure directly the reading and trying to find out a pattern in variability in the units we have here.
    I’ll keep you posted about release, currently I am testing the sequencers.
    Several issues you have sent in are being managed. I will issue a report of new features/fixes when we deliver the new firmware.


    Davide Mancini

    (to altmag, for the pitch thing)
    Ok we are checking ingto this issue. As we are not able to reproduce we will do some ‘repetitions’ on the DAC configuration sequence, the only place were something like this could be triggered (even if it’s not clear how!).



    Interesting – did a few more checks this evening.
    Clock from ERM Multiclock (analog out) into arches clk in.
    At first seemed to act strange and I just could not get it to work correctly.
    Then all of a sudden the arp from arches acts correctly and in time.. not sure how or why?
    Maybe not registering the setting when pressing the knob function. The only other thing a noticed is there seems to be a little Latency between finger key press and sound.

    Hopefully, once all the features are there later firmware upgrades can be more of refinements. I’d be still worried playing arches live, in that one minute it would work, but the next not. So refinement and stability after all the features are implemented is a must.

    I understand the enclosure thing… I can understand the thinking behind stand-alone/Eurorack. To be be honest Euroracking an Arches would, for me anyway, would be a waste of good module space. So I was never going to rack mine but would be interested in a new design enclosure if it made the playing experience better. I’ve sort of got use to the screws on the front panel.



    Okay, I tested the MIDI Clock situation in several setups, and the only thing that seems to work reliably is the CKIN out.
    I tested it as a Clock out using USB to my Endorphines Shuttle Control which I did not get to work. Also I can not make it work using my Mac. In both cases I was able to receive note on/off via MIDI, but not the clock.
    Then I tried to use my Prophet XL to send clock via MIDI DIN to the arches. Did not work.
    Then I tried to use my Waldorf kb37 to send clock via MIDI DIN to the arches. Did not work.
    Needless to say that the arches is pretty much useless in a larger setup unless it can be integrated as a master clock or as a slave using either MIDI DIN or MIDI USB.
    When will be the next firmware release fixing at least all the clock issues? Without a working clock the upcoming arpeggiater functions will be worthless to me, so this is basic functionality that we need to be able to rely on.



    Yes – clocking in essential.

    It would also be good to enable one of the mini-screen LEDs to indicate tempo when using the4 internal clock, and to indicate the recognition of received external clock and use the OLED screen to display the tempo of the received clock.



    Oh yes! Visual feedback and clear indicators to see that it is working. So much of my clock testing was guesswork. A clear visual feedback like blinking LED for the clock, no matter of internal or received external would be helpful.



    Thanks for 1.1. It’s definitely a lot closer to what I was expecting. Here’s some thoughts/findings from today’s testing.

    Clear All option – trying to start with a blank slate and for reason’s I can’t work out, cannot assign outputs 4 and 5 even though I’ve checked all the KBs and options I could but couldn’t find anything.

    The step sequencer is crying out for the top button of each strip to act as an on/off mute type button.

    When using the 3rd strip on the left hand side as a free element, the hold button does not become active regardless of what I do and the strip cannot be held.

    The top 5/6 button bleed issue is still very much there, as is a triggering of the right hand strip and button on the left if your hand brushes the soundmachines logo in the middle.

    An output reset would be useful (panic button) as I’ve found myself getting randomly stuck notes using cv/gate which I can only unstick by pulling the power.

    I would still find being able to edit all of the elements from the same context menu more useful that in/out/move/in as present. ie. Press gate edit button set gate, move the left hand encoder to the next element, set the gate setting, left hand encoder again, next element. I just find the edit process really clunky still, more so now we’ve extra layers with the sequencers.

    A couple of times I’ve *lost* the led on the top left hand strip element. It still works as it’s supposed to but for some reason the LED just decides it’s not going to light (hard reboot fixes).

    Slightly odd bug with the trigger sequencer earlier that I’ll need to try again. I had the bottom row set to 7 steps and all the other steps set to 8 but what was happening was the other channels were sounding 7 steps and a rest (the 8th beat of the bar was not sounding even though it was sequenced), starting/stopping and changing the step count on the first row seemed to fix this though.



    Hi Davide and SM team. Agree with dfyans about 1.1
    I was focusing mainly on sequencer features and has the same observation with trigger sequencer.
    1st one is definitelly influencing other trigger sequencers when running in parallel. If I change 1st trigger seq to less steps than it is influencing all other trigger sequencers. this happens only with 1st trigger (bottom row) and did not observe similar this with trigger 2-5
    e.g. when 1st has 7 steps and other has 8 than 8 on other is not active or when channging this during running I cant switch of (mute) trigger on others, when step is active on the others it will switch on this step again. It look like for proper functioning you cant use less than 8 step trigger on first one (bottom row).

    agree with dfyans also with mute or gate off for step sequencer, this will be really nice feature.



    MIDI – I can get MIDI notes, CCs and clock out of the MIDI OUT DIN port, but nothing from the USB port.

    Arches is recognised in my Mac System Report, either connected directly to a USB port or via a USB hub..

Viewing 15 posts - 16 through 30 (of 82 total)

You must be logged in to reply to this topic.