What if I want the original firmware back

Home Forums Products NS1nanosynth What if I want the original firmware back

This topic contains 10 replies, has 4 voices, and was last updated by  nickgrainwing 6 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #2984


    Hello, new user.

    Maybe I missed something about arduino, but… if I upload a new custom firmware, and decide I don’t want it anymore… how do I restore the orginal one?



    Hi zingus.

    Here you have all information: https://www.sound-machines.it/forums/topic/basic-firmware-information-and-questions/
    NO_MOZZI is a update of the custom firmware.



    Thank you! So we start with a “git clone https://github.com/SOUNDMACHINES/NS1nanosynth_sketches.git

    But where do we get the rest of the dependencies? “Wire”, “TimerOne”…



    Just stating this because these don’t compile out of the box.
    And I think a small toolkit that “just does it”, as long as you have the arduino IDE, would be a good idea.



    Well it is a hack synth. And if you work with this system it is good to know the compnents and libary it is made of you know so when someone changes a repo you know what to do. 😉

    I have some other intructions I wrote myself I can give.

    I don’t take responsability to dead url or bad speeling.



    Arduino setup for nanosyth:
    This is a mixture of https://www.sound-machines.it/forums/topic/correct-setup-for-uploading-patches/

    And some standard aruino setup.

    1) Download a Arduino desktop IDE: https://www.arduino.cc/en/main/software follow the instructions.
    2) Open Arduino
    3) Goto menu Arduino ->preference
    3.1) In ‘additional board manader’ add url: https://adafruit.github.io/arduino-board-index/package_adafruit_index.json that is to get the right board/core layout.
    4) Install MIDI support:
    4.1) Go to https://github.com/exscape/electronics, download zip and unzip it.
    4.2) Go to menu Arduino->Include library->[from zip
    4.3) Select folder in step (4.1)]->Ardunio->Libraries->DAC_MCP49xx
    4.4) Go to Arduino->Board->Board Manager. Then shoose Leornardo USB midi something.

    Tell me if something does not work.


    • This reply was modified 3 years, 8 months ago by  Niklas.


    Wow @Niklas THANKS for posting this step by step guide. I’ll let you know if it helps, because I also got to a place where I overwrote the firmware and was unable to compile and install the original firmware.

    I got a second nanosynth, which is a blast, so even without the Arduino capabilities I’ve got a lot of possibilities to explore.




    @Niklas OMG OMG OMG it worked it worked your instructions worked! THANK YOU.

    @zingus, follow the Niklas road and you will arrive at happiness.

    I was able to compile and upload the magical MODLFO by Matthew Friedrichs https://github.com/matthewfriedrichs/Modulatable-LFO-for-NS1

    I got some error messages but I clicked UPLOAD ANYWAY and it WORKED.

    Just forge ahead, and you will likely see the magical words UPLOAD DONE.

    Let us know!



    Glad it worked christian! 🙂 Did you remember what error message you got? I can then put that into descrition as a troubleshooting for other participants.



    Here is the “error” message I got but the code compiled anyway and I was able to upload and run it on my NS1. Do not worry if you see this. Maybe somebody could tell me what I could do differently, but as I say it’s running fine.

    WARNING: Category '' in library EEPROM is not valid. Setting to 'Uncategorized'
    WARNING: Category '' in library SPI is not valid. Setting to 'Uncategorized'
    WARNING: Category '' in library SoftwareSerial is not valid. Setting to 'Uncategorized'
    WARNING: Category '' in library Wire is not valid. Setting to 'Uncategorized'
    Warning: platform.txt from core 'Leonardo & Micro MIDI-USB (arcore)' contains deprecated recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", automatically converted to recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Consider upgrading this core.
    Archiving built core (caching) in: C:\Users\CHRIST~1\AppData\Local\Temp\arduino_cache_920771\core\core_arcore_avr_leonardo_5112aca257bfec713bd9d7a38edbbb58.a
    Bootloader file specified but missing: C:\Users\Christian\AppData\Local\Arduino15\packages\arcore\hardware\avr\1.0.0\bootloaders\caterina\Caterina-Leonardo.hex
    Sketch uses 15470 bytes (53%) of program storage space. Maximum is 28672 bytes.
    Global variables use 955 bytes (37%) of dynamic memory, leaving 1605 bytes for local variables. Maximum is 2560 bytes.


    Troubleshooting missing dependencies:

    I notice now when I installed Arduino on my Raspberry Pi that you can get missing dependencies like ‘TimerOne.h: No such file or directory’.
    The thing that worked for me was:

    1) Go to Sketch->Include Libary->Manage Libaries
    2) Search for the missing header name e.g. ‘TimerOne’ and install it.

    Hope that it helps someone.



    I am getting errors when compiling. I have followed all your help to get it up and running but still can’t figure it out. Below are my errors, I really want to start uploading my own sketches but I want to be able to go back to the original sketch if I mess up.

    /Users/grainwing/Documents/Arduino/Arudino Files/NS1nanosynth_sketches-master mozzi/NS1NANOSYNTH_BASE_NO_DIGIPOT/NS1NANOSYNTH_BASE_NO_DIGIPOT.ino: In function ‘void updateControl()’:
    NS1NANOSYNTH_BASE_NO_DIGIPOT:71:9: error: ‘MIDIUSB’ was not declared in this scope
    while(MIDIUSB.available() > 0) {
    NS1NANOSYNTH_BASE_NO_DIGIPOT:73:7: error: ‘MIDIEvent’ was not declared in this scope
    MIDIEvent e;
    NS1NANOSYNTH_BASE_NO_DIGIPOT:74:7: error: ‘e’ was not declared in this scope
    e = MIDIUSB.read();
    exit status 1
    ‘MIDIUSB’ was not declared in this scope

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.